Networking DVR’s – A General Guide
Ethernet Cables
There are two types of Ethernet cables used in networking; Crossover and
Patch. For PC to DVR (no router or hub) a Crossover is used.
When wiring through a Router or Hub a patch cable is used.
A patch can be either Type A or Type B wiring just as long as it is the same at
both ends of the cable.
A Crossover is Type A at one end and Type B at the other end.
The image below is a wiring diagram for Type A and Type B:

IP Addresses.
The IP address is a “unique” sequence of numbers that identifies the DVR or other
network device on a network and places it into an IP class. This is comprised of a
sequence of 4 batches (Octets) of 3 digit numbers which are then each separated by a
full stop. e.g. 192.168.0.10, you can think of it as the PC equivalent of a postcode.

Subnet Mask.
The Subnet Mask is a sequence of numbers that masks over a section of the
devices IP address where this section is the same for each device connected to
the network. Where a “0” is present is where the digits in the IP addresses are
unique so as to identify the different devices.
Where 255’s are present is where the digits in the IP address are masked over
and are unimportant.
For example:
Computer IP Address
192.168.0.100
Subnet Mask
255.255.255.0
Gateway
192.168.0.1

DVR IP Address
192.168.0.200
Subnet Mask
255.255.255.0
Gateway
192.168.0.1

Gateway.
The Gateway is used when the DVR is connected to the internet. The
Gateway address matches that of the INTERNAL address of the router that
the DVR is connected to. You can easily retrieve the routers internal
address by using the “ipconfig” command detailed further below.
The following example is based on the router’s internal address being 192.168.0.1.
Computer’s IP Address
192.168.0.100

DVR IP Address
192.168.0.200

Subnet Mask
255.255.255.0

Subnet Mask
255.255.255.0

Gateway
192.168.0.1

Gateway
192.168.0.1

If you are unsure of the current PC IP address or the routers internal address then
there is a simple tool you can use that all Windows PCs have. Hold down the
“Windows/Start” key and press “R”, in the Run box that appears type “cmd”
(without the “ “) and hit enter, on Windows XP you will be displayed with
something similar to the image below:

On Windows Vista and Windows 7 it will look slightly different:

You may notice that on Windows Vista and Windows 7 the IP Address is referred
to as IPV4, this is still the same as when you run ipconfig on a Windows XP
machine it is just worded differently.

Testing IP Addresses

Note: The images in this section are taken from a Windows XP
Computer, the methods listed below work almost identical on Windows
Vista and Windows 7 but may be displayed slightly differently.
To determine whether an IP address is already in use by another device on
the network, there are a few simple checks you can make:
First you will need to open the command prompt (Hold down the Start/.Windows
key and press “R”

Then in the Run window type “CMD” and press enter.

To check if an IP Address is in use by another device on the network type ‘PING’
followed by a space and then the desired IP address for the DVR followed by
Enter. If after running the PING command there is a reply, it means that the IP
address is already in use and you will need to find an alternative one for the DVR.
If you get an error such as ‘Destination Host Unreachable’ or ‘Request Timed Out’
it most likely means the IP address is available for use.
(You may also get an error if your computer is not set to the same address range
as the machine you are trying to contact.)

You can also use the PING command to check whether the DVR is connected and
responding by typing the PING command followed by the IP address of the DVR
and checking that the DVR is communicating on the network
If it does reply it will look similar to the following example:

Please note that the IP addresses shown above may be different than
those you will actually use and should be referred to only as examples.
If you have connected your DVR directly to a PC via a crossover cable then you will
probably get the message “Request Timed Out” or “Destination Host Unreachable.” All
that this means is that your PC is likely to have been set for DHCP (Dynamic Host
Control Protocol) which means in essence that the PC is given the network settings
from a DHCP Server, most commonly a router. This is likely to be the case with
around 95% of all pc’s on the planet. When a PC is configured in this way and there is
no DHCP server attached then the PC will not have any network settings set.

To manually configure the IP address of the PC you are tying connect you will
need to turn off DHCP and set the network settings for Static. To do this, take a
look at the following examples:

In Windows XP go to:
Control Panel>Network Connections and locate the Local Area Network
Connection (Not the 1394 or Wireless connection)>Right Click Local
Area Connection>Properties>Click and Highlight Internet Protocol
(TCP/IP)>Select “Use the Following IP Address”
In Windows Vista and Windows 7 go to:
Control Panel> Network & Sharing Centre (you may have to click on “classic
view” in the top left of the Control Panel Window)>Manage Network
Connections>Right Click Local Area Connection>Properties>Internet Protocol
Version 4 (TCP/ IPV4)>Select “Use the Following IP Address”

Type in an IP address that is similar to the DVR. Example: PC is 192.168.1.50
where the DVR might be 192.168.1.200, the key to success with this exercise is
that the first 3 groups of digits must be identical to the DVR’s IP address but the
last 3 digits need to be similar but not necessarily consecutive.
When you click on Subnet Mask one should appear automatically which should
do just fine. If you are connecting the DVR via a crossover lead then there is no
need for a Gateway address, however if it makes you feel better then feel free
to enter one.
Assuming all is well you should be able to successfully Ping the DVR which
proves you have a good network connection.

Internet Access.

Router Setup.

Please refer to the installation disk or documentation that came with the router
for its specific IP address details.

Ports
Each DVR or device uses virtual ports to stream images from the DVR to a
remote computer. These ports need to be configured in the router to allow
communications to the DVR’s IP address via the internet (Ports do NOT need
forwarding in the router to connect on a LAN connection). They can often be
found in the DVR’s network menu or accompanying manual and viewer software.
There are so many different brands and models of routers that they cannot be
shown here, please refer to the manufacturers manual of your router on how or
have a look at some of the following website and utilities.

For more information and general tips including configuring specific routers
please visit portforward.com.
There is a free utility you can download called “Simple Port Forwarding” which is
available as a download from various sites which allows you to input the specific
make and model of router, the ports you need to open and it will do it for you.
Once all of the above has been configured correctly you should be able to connect
to and control your DVR from the internet.
Different DVRs tend to use different port ranges but are normally adjustable.
Typically any DVR with a built in web browser uses port 80 by default (they may
use additional ports too), this is because port 80 is the default port for the http
protocol which is used for everyday web browsing.
When connecting via Internet Explorer if the DVR is using port 80 then all that
is needed to be typed into the address bar is the IP Address of the DVR (local
connection) or the External IP Address (Internet Connection).
If the http port has been altered to something other than port 80, then it will need
to be specified when typing the IP Address into the address bar. For example; if
the port has been changed to 85 and the DVR IP Address is 192.168.0.100 then
the following would need to be typed into the address bar:
http://192.168.0.100:85
You must remember the http:// prefix at the start when using a port
other than port 80 or else you will not get a connection.
Another handy website for use when forwarding ports is http://www.ping.eu

External IP Address
In order to connect over the internet you will need to use the External IP address
of the router (as provided by your Internet Service Provider) as the IP address to
connect to. If you are unsure of the external IP address of the router you can visit
Portforward.com or whatismyipaddress.com from a computer that is connected to
that router, the external IP address of your router will be displayed on the
webpage.
It is recommended that you or your client request a static IP address from the
Internet Service Provider (ISP) in order to have a reliable remote viewing
connection as the majority of ISP’s use dynamic networks. What this means is
that a new external IP address may be assigned to your router at random
intervals, resulting in not being able to connect to the DVR from the internet until
the new IP address is realized and used.
A static IP address is where the ISP specifically reserves an IP address for you so
that it will never change; this is often available upon request from your ISP.
However it is always a good idea to double check that it is correct before trying to
access your DVR across the internet, you can check this by visiting

http://www.whatismyipaddress.com from any computer connected to the same
router as the DVR.
Typically if you can connect to the DVR internally across the network then you
should be able to access it from the internet as long as the port forwarding in the
router and gateway address in the DVR are correct.

DDNS
In the event of being unable to provide a static IP address you may have to
use a DDNS provider (Dynamic Domain Name Service).
DDNS works by receiving updates via a DVR, Client Update software (running on
a PC) or router alerting it to the fact that the External IP Address on site has
changed. Instead of connecting to the DVR by typing the External IP Address into
your DVR software or Internet Explorer you access it by typing a domain name.
Note: To register and setup a DDNS account is typically free, however
depending on how often the IP Address on site changes and is updated you
may have to pay a fee to upgrade your account. Please see the terms and
conditions for the DDNS provider you are using for more information.

The first thing to do is to create an account with a DDNS provider
such as www.dyndns.org which is the site used in the following example.
Once you have setup an account you can add a host service.
What you do here is choose a domain name for connecting to your DVR,
for example; http://mydvr.dyndns.org
Enable the option to host with IP Address and you can then enter the
current External IP Address in to the field provided.
See image below

Once done just add to cart.
All that is required after setting up your service is to configure the device you are
going to use to update the IP Address with your account settings. This can be a
DVR (if the feature is available); a PC (requires downloading the update client
from the provider’s website) or the Router on site (if the feature is available).
The settings you would need to add into your chosen device would be the following:








account username and password 
domain name(i.e.: http://mydvr.dyndns.com ) 
The provider you are using. 

If you choose to use the DVR to update the IP Address you MUST make sure that
the correct DNS addresses are set in the DVR network menu, these can normally
be found in the menus of your Router. They are quite often displayed on a
“Status” or “Overview” page. Typically there are two DNS Addresses, a primary
and a secondary.

Failure to set the correct DNS Addresses in the DVR will result in the
DVR not being able to communicate with the DDNS provider website,
thus not updating the IP Address.

Email
If your DVR supports email and you would like to be notified of certain events in
this way then you will need to create the DVR its own email account.
Once you have an account created for the DVR then all you need to obtain are the
details the DVR needs to be able to send an email using that account, the details
the DVR will most likely needs are:
Username for the email account
Password for the email account
SMTP Server for the email account (this is the server that sends the email to
the receiving accounts).
Port Number: 25 in most cases

Once you have entered the relevant information for the account you can add the
receiver emails. After that email should be up and running. DO NOT forget to set
the correct DNS addresses in the DVR otherwise the email feature will not work.
Note: Some email accounts use an Encryption method called SSL, at
this moment in time Cop DVRs do NOT support SSL Encryption.

Trouble Shooting

There may be conflicts within the operating system itself to prevent the viewing
application from displaying the recorders retrieved images correctly or at all.

If you are having trouble installing an Activex control on Internet Explorer try
adjusting the Activex options in Tools>Internet Options>Custom Level and then
scrolling down to the Activex and Plug-ins section. In this section make sure
Activex controls are enabled and that Downloading Unsigned Activex Controls is
set for Prompt. Also it can be worth adding the DVR as a trusted site.

If you can log into the DVR but are experiencing a blank or silver viewing window
or general problems with the images then please ensure that you have the latest
display drivers for your computer by connecting it to the internet and checking
for updates. You may have to refer to the graphic adapter manufacturer for
information on updating your drivers.
In the event of image problems occurring try the following things:












Make sure the latest Display Drivers are installed and operating correctly
on the PC you are viewing from. 
If using multiple monitors from one PC try it on the other monitor. 
Try adjusting your resolution on the PC, does this make any difference? 
Hold down the Windows/Start key and press “R” then type “dxdiag” and hit
enter, this will give you the directx diagnostic tool. Click on display and check
that Direct Draw Acceleration and Direct 3D Acceleration are enabled. 
Make sure any Codec packs such as Divx etc that come with the DVR
are installed. 

